ГлавнаяИнформацияСтатьиПрименение ставок налогов 2018 года в конфигурации «Бухгалтерский учет для Казахстана» на платформе 1C 7.7

Применение ставок налогов 2018 года в конфигурации «Бухгалтерский учет для Казахстана» на платформе 1C 7.7

В 2018 году изменились ставки социального налога и социальных отчислений. Конфигурация «Бухгалтерский учет для Казахстана» на платформе 7.7 оказалась совсем не готова к этим переменам. МРП и МЗП устанавливаются в константах (меню «Операции — Константы»), с этим сложности нет.

Появляются сложности при установке новых значений социального налога и социальных отчислений. Ставка социального налога устанавливается в справочнике «Налоги, сборы, отчисления» (меню «Справочники — Налоги и платежи в бюджет»). Можно либо добавить новую запись по социальному налогу, либо отредактировать уже существующую — при записи справочника, если вы изменили ставку, будет задан вопрос с какой даты действует новая ставка. Ставку мы таким образом поменяем, но работать она еще не будет.

Далее, чтобы заработала новая ставка социального налога, и чтобы установить новую ставку социальных отчислений, нужно дорабатывать конфигурацию.

Касательно социального налога нам нужно изменить функцию «ПолучитьВидСоциальногоНалога» в модуле документа «ВедомостьНачислений». Она должна принять следующий вид:

Функция ПолучитьВидСоциальногоНалога(Работник)
	СоциальныйНалог = "";
	
	Если ДатаДок >= Дата(2018, 01, 01) Тогда//++
		Если Работник.ИностранныйСпециалист = 1 Тогда
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалогИностранныйСпециалист",11,1,ДатаДок);
		ИначеЕсли Работник.Инвалид.Получить(ДатаДок) = 1 Тогда                              
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалогИнвалид",4.5,1,ДатаДок);
		Иначе	
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалог",9.5,1,ДатаДок);
		КонецЕсли;
	
	ИначеЕсли ДатаДок >= Дата(2009, 01, 01) Тогда
		Если Работник.ИностранныйСпециалист = 1 Тогда
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалогИностранныйСпециалист",11,1,ДатаДок);
		ИначеЕсли Работник.Инвалид.Получить(ДатаДок) = 1 Тогда                              
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалогИнвалид",4.5,1,ДатаДок);
		Иначе	
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалог",11,1,ДатаДок);
		КонецЕсли;       
	     
	ИначеЕсли ДатаДок >= Дата(2004, 01, 01) Тогда
		Если Работник.ИностранныйСпециалист = 1 Тогда
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалогИностранныйСпециалист",,1,ДатаДок);
		ИначеЕсли Работник.Инвалид.Получить(ДатаДок) = 1 Тогда                              
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалогИнвалид",6.5,1,ДатаДок);
		Иначе	
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалог",,1,ДатаДок);
		КонецЕсли;       
	
	Иначе
		Если Работник.ИностранныйСпециалист = 1 Тогда
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалогИностранныйСпециалист",11,1,ДатаДок);
		ИначеЕсли Работник.Инвалид.Получить(ДатаДок) = 1 Тогда                              
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалогИнвалид",6.5,1,ДатаДок);
		Иначе	
			СоциальныйНалог = глПолучитьНалог("СоциальныйНалог",21,1,ДатаДок);
		КонецЕсли;       
	КонецЕсли;
	
	Возврат СоциальныйНалог;   
	
КонецФункции

Суть сводится к тому, что если дата документа начисления больше 01.01.2018, то программа будет искать запись по социальному налогу со ставкой 9,5 %.

Касательно социальных отчислений нам нужно изменить функцию «глПолучитьСтавкуСоциальныхОтчислений» в глобальном модуле конфигурации. Она должна принять следующий вид:

Функция глПолучитьСтавкуСоциальныхОтчислений(ДатаРасчета) Экспорт
	Ставка = 2; // 2% с 01.01.2006, как значение по умолчанию в случае, если период платежа не заполнен
	
	Если ДатаРасчета >= Дата(2018, 01, 01) Тогда//++
		Ставка = 3.5 ; // 3,5% с 01.01.2018				
	ИначеЕсли ДатаРасчета >= Дата(2010, 01, 01) Тогда
		Ставка = 5 ; // 5% с 01.01.2010				
	ИначеЕсли ДатаРасчета >= Дата(2009, 01, 01) Тогда
		Ставка = 4 ; // 4% с 01.01.2009				
	ИначеЕсли ДатаРасчета >= Дата(2007, 01, 01) Тогда
		Ставка = 3 ; // 3% с 01.01.2007					
	ИначеЕсли ДатаРасчета>= Дата(2006, 01, 01) Тогда
		Ставка = 2; // 2% с 01.01.2006			
	ИначеЕсли ДатаРасчета>= Дата(2005, 01, 01) Тогда
		Ставка = 1.5; // 1,5% с 01.01.2005						
	КонецЕсли;                                              
	
	Возврат Ставка;	
КонецФункции

В этом случае добавлено условие о том, что если дата документа начисления больше 01.01.2018, то программа применит ставку 3,5 %.

Работа проводилась с релизом 7.70.281 типовой конфигурации «Бухгалтерский учет для Казахстана».

Опубликовано 12.01.2018. Автор — Антон Колимбетов.