ГлавнаяИнформацияРазработчикамВыгрузка области данных excel в многомерный массив

Выгрузка области данных excel в многомерный массив


Процедура КнопкаВыполнитьНажатие(Кнопка)

Документ = ПолучитьCOMОбъект(Файл);
ПоследняяСтрока = Документ.ActiveSheet.UsedRange.Rows.Count;
КоличествоКолонок = Документ.ActiveSheet.UsedRange.Columns.Count;
Лист = Документ.ActiveSheet;
Область = Лист.Range(Лист.Cells(1, 1), Лист.Cells(ПоследняяСтрока, КоличествоКолонок));
МассивДанных = Область.Value.Выгрузить();

// Последующая обработка массива

КонецПроцедуры

Процедура ФайлНачалоВыбора(Элемент, СтандартнаяОбработка)

ДиалогФыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ДиалогФыбораФайла.Фильтр = "Файлы xls (*.xls)|*.xls";
ДиалогФыбораФайла.Заголовок = "Выберите файл";
ДиалогФыбораФайла.ПредварительныйПросмотр = Ложь;
ДиалогФыбораФайла.Расширение = "xls";
ДиалогФыбораФайла.ИндексФильтра = 0;
ДиалогФыбораФайла.ПолноеИмяФайла = Элемент.Значение;

Если ДиалогФыбораФайла.Выбрать() Тогда
Элемент.Значение = ДиалогФыбораФайла.ПолноеИмяФайла;
КонецЕсли;

КонецПроцедуры

 

Скачать пример

Опубликовано 25.12.2013. Автор — Антон Колимбетов.